Installazione della lingua R su Ubuntu 16 – dependencies non soddisfatte

Installazione del linguaggio R seguendo le istruzioni del sito [ qui ].

Durante l'installazione ricevo un errore " dependencies non soddisfatte " al componente r-base usando il command apt-get install. Vedere il log con la seguente sequenza di command:

apt-key adv --keyserver keyserver.ubuntu.com --recv-keys E298A3A825C0D65DFD57CBB651716619E084DAB9 Executing: /tmp/tmp.QQyv0HB7mS/gpg.1.sh --keyserver keyserver.ubuntu.com --recv-keys E298A3A825C0D65DFD57CBB651716619E084DAB9 gpg: requesting key E084DAB9 from hkp server keyserver.ubuntu.com gpg: key E084DAB9: "Michael Rutter <[email protected]>" not changed gpg: Total number processed: 1 gpg: unchanged: 1 /data/shared/datascience# add-apt-repository 'deb [arch=s390x] https://cran.rstudio.com/bin/linux/ubuntu xenial/' apt-get update Hit:1 https://cran.rstudio.com/bin/linux/ubuntu xenial/ InRelease Hit:2 http://ports.ubuntu.com/ubuntu-ports xenial InRelease Get:3 http://ports.ubuntu.com/ubuntu-ports xenial-updates InRelease [102 kB] Get:4 http://ports.ubuntu.com/ubuntu-ports xenial-security InRelease [102 kB] Get:5 http://ports.ubuntu.com/ubuntu-ports xenial-updates/main s390x Packages [554 kB] Get:6 http://ports.ubuntu.com/ubuntu-ports xenial-updates/universe s390x Packages [494 kB] Fetched 1252 kB in 12s (104 kB/s) Reading package lists... Done apt-get install r-base Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: r-base : Depends: r-base-core (>= 3.4.0-1xenial0) but it is not going to be installed Depends: r-recommended (= 3.4.0-1xenial0) but it is not going to be installed Recommends: r-base-html but it is not going to be installed Recommends: r-doc-html but it is not going to be installed E: Unable to correct problems, you have held broken packages. 

È questo un errore nella mia procedura di installazione, o è questo pacchetto rotto?

Utilizzando il repository Universal Ubuntu e il command riportto di seguito, il problema è stato risolto:

 sudo apt-get install r-base r-base-dev